Con Qt 5 ampliamente adoptado por los desarrolladores de aplicaciones Qt y otros proyectos importantes, como el entorno de escritorio KDE Plasma, las tecnologías Qt 4 se vuelven obsoletas, por lo que cada vez más distribuciones GNU/Linux planean su eliminación completa de los repositorios de software.

Los equipos Qt/KDE de Debian Project ya se están preparando para eliminar el soporte de Qt 4 de los repositorios de la próxima serie del sistema operativo Debian GNU/Linux 10 “Buster” principalmente porque es cada vez más difícil mantenerlo ahora que ya no es compatible con el flujo ascendente. y puede causar muchos problemas en todo el sistema.

“Actualmente, Qt 4 ha estado en la fase inicial, y estamos empezando a tener problemas para mantenerlo, como por ejemplo en el caso de soporte de OpenSSL 1.1”, dijo Simon Quigley en el informe de error. “Ningún paquete nuevo que ingrese al archivo de Ubuntu debe depender de qt4-x11 o de cualquier paquete que dependa directa o indirectamente de él”.

En este momento hay más de 330 paquetes marcados para su eliminación, incluidos grandes nombres como LibreOffice (libreoffice-kde), LightDM y todo el Stack KDE 4. Estos se eliminarán si no se actualizan a una versión basada en el marco Qt 5, pero el equipo también está purgando paquetes obsoletos que no se han mantenido en años.

Se insta a todos los mantenedores de aplicaciones a portar sus paquetes a Qt 5

Este es una llamada para que los desarrolladores comiencen a portar sus aplicaciones Qt 4 o cualquier otro paquete que dependa de qt4-x11, directa o indirectamente, al último marco Qt 5, que es totalmente compatible con versiones actuales y futuras de Ubuntu. Los desarrolladores deben cargar versiones de Qt 5 de sus aplicaciones a la versión de desarrollo antes de Ubuntu 19.04.

En este momento, Canonical se prepara para lanzar su séptima versión de LTS (soporte a largo plazo), el Ubuntu 18.04 LTS (Bionic Beaver), que todavía admitirá aplicaciones Qt 4, especialmente que numerosos usuarios de Ubuntu 16.04 LTS (Xenial Xerus) planean actualizarla , pero Ubuntu 18.10 podría ser el primer lanzamiento para enviar sin soporte Qt 4.

Por supuesto, la eliminación del soporte Qt 4 tendría un mayor impacto en los sabores de Ubuntu como Kubuntu o Lubuntu Next, ya que dependen de las tecnologías Qt/KDE más que Ubuntu, que usa la pila GNOME basada en GTK +. Pero es una jugada excelente ya que el mundo de Linux necesita adaptarse a tecnologías nuevas y más potentes, siempre.

Original

(Visitada 1 veces, 1 visitas hoy )